evolutionm.net - Home of the Lancer Evolution
Home Features Community Marketplace Registry Garage Store

Go Back   evolutionm.net > Lancer Evolution 1-9 Forums > Evo Engine / Turbo / Drivetrain
Sign in using an external account
Register Forgot Password?
Register Photos FAQ Members Calendar Search Today's Posts Mark Forums Read Used CarsGarageVendor Directory
Search


Evo Engine / Turbo / Drivetrain Everything from engine management to the best clutch and flywheel.
Sponsored by: World Racing

Welcome to EvolutionM.net!
Welcome to EvolutionM.net.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
Thread Tools Search this Thread
Old Jun 30, 2009, 02:09 PM   #1
Evolving Member
Personal Sales Rating: (1)
Garage is empty, add now
 
C_LosEvo's Avatar
 
Join Date: Oct 2007
Location: Los Angeles, CA
Posts: 173

Drives: 05 Evo 8

Weird clicking noise when i press gas pedal

While driving every time i press on the gas pedal i hear a "click click" and goes away. The noise is coming from the front under driver side. I lifted the car and looked to see if the drive shaft is touching anything but it seems fine. any guesses?
Offline
 
Reply With Quote
Old Jul 1, 2009, 10:16 PM   #2
Newbie
Personal Sales Rating: (7)
Garage is empty, add now
 
Join Date: Mar 2008
Location: KY
Posts: 50

Drives: 03 TB Evo

Could it be a relay switching?
Offline
 
Reply With Quote
Old Jul 2, 2009, 07:46 PM   #3
Newbie
Personal Sales Rating: (0)
Garage is empty, add now
 
Join Date: Apr 2007
Posts: 40

i dont know it you have done any exhaust work or taken the the lower bars that goes across the exhaust. forgot what there called. but check the chrome spacers that go in between the bar and the frame to create a gap so the downpipe isnt hitting the small black bar.

i stuck the spacer on backwards and when i would hit the gas the downpipe would make a tapping noise on that bar.
__________________
EVO IX Mods, Evo Green, LICP, 1000cc injectors, Walbro fuel pump, Aem short ram, dejon dual boost contoller, Turbo XS TBE, Test Pipe, slow boy FMIC, HKS 272 cams, Megan 02, ets short route uicp, 65,, Throttle body, Ported intake mani, tuned by Mr Gray.
Offline
 
Reply With Quote
Old Jul 2, 2009, 07:56 PM   #4
Evolved Member
Personal Sales Rating: (22)
Garage is empty, add now
 
Join Date: Sep 2005
Location: MD/PA line
Posts: 2,323

Drives: BBK powered EVO 8

Send a message via AIM to Cali2MDevo8
My clutch pedal makes that little squeak noise. Not the gas pedal though.
Offline
 
Reply With Quote
Old Jul 4, 2009, 06:26 AM   #5
Evolved Member
Personal Sales Rating: (30)
Garage is empty, add now
 
EVO8emUp's Avatar
 
Join Date: Jul 2004
Location: Wheeling, WV
Posts: 1,228

Drives: '05 MR

It should be doing it around 0-1psi. I believe it's the fuel pump relay.
__________________
EVOLUTION VIII MR
Offline
 
Reply With Quote
Old Jul 4, 2009, 06:43 AM   #6
Evolved Member
Personal Sales Rating: (21)
Garage is empty, add now
 
fqjdmct9a's Avatar
 
Join Date: Jun 2008
Location: Orlando, FL
Posts: 549

Drives: WW IX

i been having the same problem lately i just hear a "click"
Offline
 
Reply With Quote
Old Jul 4, 2009, 06:55 AM   #7
Evolved Member
Personal Sales Rating: (1)
2005 Mitsubishi Lancer Evolution
 
WRC-LVR's Avatar
 
Join Date: May 2008
Location: Marietta GA
Posts: 711

Drives: 2005 EVO MR

gm 3 port solenoids make this sound. Fair number of people have made the comment. Mine does it.

Hope this helps

milburn
__________________
2005 Apex Silver MR => Swift Spec-R, Progress 25mm RSB, Perrin Stout mounts, 255-40-17 Z1 Star Specs, Blox front engine mount, ES FSB bushings, WL rear bumpsteer kit and trailing arm bushings, SuperPro eccentric rear lower control arm bushings , front and rear undertrays, Trustz gauge overlays, Autometer EGT, Oil Pr, Boost, Water Tmp, LC-1 w G5, JDM IX DV, custom heat wrapped downpipe, Magnaflow axleback, GM 3 port, selftuned...330wtq 320 whp VD .
Offline
 
Reply With Quote
Old Jul 4, 2009, 07:25 AM   #8
Evolved Member
Personal Sales Rating: (21)
Garage is empty, add now
 
fqjdmct9a's Avatar
 
Join Date: Jun 2008
Location: Orlando, FL
Posts: 549

Drives: WW IX

^^^??
Offline
 
Reply With Quote
Old Jul 5, 2009, 03:56 PM   #9
Newbie
Personal Sales Rating: (7)
Garage is empty, add now
 
Join Date: Feb 2009
Location: Hickory, NC
Posts: 79

Drives: 03 VIII

wierd exhaust leak??!?!
__________________
old: FP Green, E85 442whp 442ft lbs

Tuned by Kasey

New: Fp Red, E85, 264s, stock motor 501whp
Stock Ecu

94 Supra TT 6Speed Billet 6765
Offline
 
Reply With Quote
Old May 4, 2011, 04:08 AM   #10
Evolved Member
Personal Sales Rating: (2)
Garage is empty, add now
 
IS2000's Avatar
 
Join Date: Jan 2003
Location: SoCal - Bangkok
Posts: 784

Drives: EVO8, 335i, 997C2S (gone), Mini Cooper S'(sold), VW Passat (sold), S2000 (sold), IS300 (traded for EVO)

Bumping up this old thread,
Recently I also noticed every time I pressed the gas pedal (about 10-15% in) there's a clicking sound coming from the pedals area. It only does this when the car is moving both in gears and in neutral. Any idea what causes this?
Offline
 
Reply With Quote
Old Oct 28, 2011, 08:57 AM   #11
Evolved Member
Personal Sales Rating: (33)
Garage is empty, add now
 
Join Date: Jul 2006
Location: 2 places
Posts: 1,240

Drives: 06 SSL and now WW X

me too, it seems like its coming from behind the hvac controls, it has to be a relay?
Offline
 
Reply With Quote
Old Oct 28, 2011, 08:57 AM
EvolutionM
Mitsubishi Lancer




Paid Advertisement
 
 
 
Reply

Tags
car, clicking, driving, gas, makes, making, noise, noises, pedal, press, pressed, pressing, push, sound, squeaky

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


 









All times are GMT -7. The time now is 06:43 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.5.2
All Passwords