evolutionm.net - Home of the Lancer Evolution
Home Features Community Marketplace Registry Garage Store

Go Back   evolutionm.net > Lancer Ralliart Forums > 09+ Ralliart Engine/Turbo/Drivetrain
Sign in using an external account
Register Forgot Password?
Register Photos FAQ Members Calendar Search Today's Posts Mark Forums Read Used CarsGarageVendor Directory TSB & Recalls
Search


Welcome to EvolutionM.net!
Welcome to EvolutionM.net.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
Thread Tools Search this Thread
Old Dec 31, 2009, 02:23 PM   #1
Newbie
Personal Sales Rating: (0)
Garage is empty, add now
 
Join Date: Jan 2009
Location: Delavan WI
Posts: 87

Drives: 09 tarmac RA

burning smell

A couple of times when I get out of my car or at a stop light I've noticed a burning smell, almost like a clutch smell. Has anyone else noticed this?
Offline
 
Reply With Quote
Old Dec 31, 2009, 02:44 PM   #2
Evolved Member
Personal Sales Rating: (1)
Garage is empty, add now
 
Join Date: Jun 2009
Location: CA
Posts: 1,127

Drives: 2011 WW GSR

Yes, but only when I've been driving in situations that would have started to cook a normal M/T clutch.
Offline
 
Reply With Quote
Old Dec 31, 2009, 08:11 PM   #3
Evolving Member
Personal Sales Rating: (1)
Garage is empty, add now
 
japan101's Avatar
 
Join Date: Feb 2009
Location: CT
Posts: 373

If your car is new it will do that for a little while. It goes away unless you are driving it hard.
__________________

Mitsubishi, Nissan, Mazda, Subaru

The Last of the Japanese performance brands forging ahead into the millenium.
Offline
 
Reply With Quote
Old Jan 1, 2010, 07:30 AM   #4
Evolved Member
Personal Sales Rating: (5)
Garage is empty, add now
 
GiLizILL's Avatar
 
Join Date: Nov 2008
Location: Ramstein Ab
Posts: 1,375

Drives: 2011 STI Stage 2

Send a message via AIM to GiLizILL
Quote:
Originally Posted by japan101 View Post
If your car is new it will do that for a little while. It goes away unless you are driving it hard.


bingo
__________________
.God over everything.
Offline
 
Reply With Quote
Old Jan 1, 2010, 07:48 AM   #5
Newbie
Personal Sales Rating: (0)
Garage is empty, add now
 
Join Date: Jan 2009
Location: Delavan WI
Posts: 87

Drives: 09 tarmac RA

I got it brand new. I've only put 1700 miles on it and I don't really drive the car hard. Thanks for the help
Offline
 
Reply With Quote
Old Jan 1, 2010, 04:13 PM   #6
Newbie
Personal Sales Rating: (0)
Garage is empty, add now
 
macgenius's Avatar
 
Join Date: Dec 2009
Location: Toronto
Posts: 12

Drives: 09 WW RA / Electric Orange Focus ST-2

I'm having the same issue. Picked up the car 2 weeks ago with 8500kms on the clock.

The other day I used the snow setting for the first time and after 15 mins of careful driving there was a really strong smell of burning clutch.

This is my first non-Ford car and I gotta say that smell seriously concerned me. I keep hearing horror stories about the SST and its got me pretty wound up.

Is it just coincidence the smell occurred after selecting the snow setting?

Any help/comments would be much appreciated
Offline
 
Reply With Quote
Old Jan 1, 2010, 04:37 PM   #7
Evolved Member
Personal Sales Rating: (1)
Garage is empty, add now
 
Join Date: Jun 2009
Location: CA
Posts: 1,127

Drives: 2011 WW GSR

Quote:
Originally Posted by macgenius View Post
I'm having the same issue. Picked up the car 2 weeks ago with 8500kms on the clock.

The other day I used the snow setting for the first time and after 15 mins of careful driving there was a really strong smell of burning clutch.

This is my first non-Ford car and I gotta say that smell seriously concerned me. I keep hearing horror stories about the SST and its got me pretty wound up.

Is it just coincidence the smell occurred after selecting the snow setting?

Any help/comments would be much appreciated

Maybe more clutch slippage for extra traction in the snow? I'm not sure, but unless the burning smell continues, I wouldn't worry about it. You could always take it into the dealer if you are really concerned.
Offline
 
Reply With Quote
Old Jan 1, 2010, 05:43 PM   #8
Gold Sponsor
Personal Sales Rating: (1)
Garage is empty, add now
 
EricJ@AMS's Avatar
 
Join Date: Jul 2004
Location: Wood Dale, IL
Posts: 1,652

Drives: 2009 Octane Blue Ralliart and AMS Drag Evo

Send a message via ICQ to EricJ@AMS Send a message via AIM to EricJ@AMS Send a message via Yahoo to EricJ@AMS
I've noticed this rubber burning smell after putting snow tires on.
__________________
Eric Jones
-ASE certified Master tech/Drag car pilot-
EricJ@amsperformance.com
AMSperformance.com

Tel. 847-709-0530
  • AMS Drag Evo VIII - 8.42 with a best trap of 171 MPH
  • World’s Most Powerful EVO – 1142 awhp
  • 2008 AMS Racing – 40 Victories in Road Racing and Hill Climb
CLICK HERE for all of our latest videos and pictures
CLICK HERE for our FACEBOOK group
CLICK HERE for up to date news, products and events at AMS
Offline
 
Reply With Quote
Old Jan 1, 2010, 05:47 PM   #9
Evolving Member
Personal Sales Rating: (1)
Garage is empty, add now
 
japan101's Avatar
 
Join Date: Feb 2009
Location: CT
Posts: 373

I have 27k on the odometer now and on my way home I have a very steep incline right before my house so on some occasions I do smell some burn like a mix of tires and tranny. It really doesn't concern me as much anymore to the fact that the car drives fine.
__________________

Mitsubishi, Nissan, Mazda, Subaru

The Last of the Japanese performance brands forging ahead into the millenium.
Offline
 
Reply With Quote
Old Jan 1, 2010, 06:49 PM   #10
Evolved Member
Personal Sales Rating: (1)
Garage is empty, add now
 
Join Date: Sep 2009
Location: Auburn, WA
Posts: 528

Drives: 2010 Octane Blue Ralliart

I get the burning smell occasionally too; and it does smell like burning rubber to me as well.

-Taranis
Offline
 
Reply With Quote
Old Jan 4, 2010, 05:17 PM   #11
Evolving Member
Personal Sales Rating: (1)
Garage is empty, add now
 
Jyrk's Avatar
 
Join Date: Mar 2009
Location: Canada
Posts: 383

Drives: 09 Lancer Ralliart

Quote:
Originally Posted by EricJ@AMS View Post
I've noticed this rubber burning smell after putting snow tires on.

yeah me too. Everything was fine 13k and no smell.. AND THEN trip to the dealer for a blown ACD pump, which hasn't been repaired yet.. and now the burning rubber smell is very strong... But i do have snow tires on (smell never started when i put them on, only after dealer visit)

Also the smell seems to come from the rear of the car.. I can notice it very heavily when i stand at the back of the car or if i reverse into a parking spot.

Maybe the blown ACD pump causing it?


Pretty much same as brad tho.
Burning smells from engine bay?
__________________
(x) Change in the ashtray
(x) a pack of gum in the cup holder
(x) performance wiper fluid
(x) oil change
(x) another pointless list nobody cares about

Last edited by Jyrk; Jan 4, 2010 at 05:23 PM.
Offline
 
Reply With Quote
Old Jan 4, 2010, 06:40 PM   #12
Newbie
Personal Sales Rating: (1)
2009 Mitsubishi Lancer
 
Doarrival's Avatar
 
Join Date: Sep 2009
Location: Brooklyn NY
Posts: 52

Drives: 2009 Ralliart

hey guys,
having the same problem also. it started as a few times when i drive, but now its up to every time i drive i smell this burning rubber smell. I thought it was the tranny. it wasnt. Then i thought it could be brake pad dusk. then i thought well i lowered my car and i have not bought the camber kit and i looked at my front inside tire and the are nearly non-existant. so i thought it maybe that. but that makes no sense...so now im back to brake pad dusk caught in my vents. if some one figures this out post it cause this is getting annoying.
Offline
 
Reply With Quote
Old Jan 4, 2010, 08:54 PM   #13
Evolved Member
Personal Sales Rating: (7)
Garage is empty, add now
 
brads09lancerGT's Avatar
 
Join Date: Aug 2008
Location: BC, Canada
Posts: 1,054

Drives: 09 Octane Blue Ralliart ...09 Lancer GTS(TOTALLED)

Quote:
Originally Posted by Jyrk View Post
yeah me too. Everything was fine 13k and no smell.. AND THEN trip to the dealer for a blown ACD pump, which hasn't been repaired yet.. and now the burning rubber smell is very strong... But i do have snow tires on (smell never started when i put them on, only after dealer visit)

Also the smell seems to come from the rear of the car.. I can notice it very heavily when i stand at the back of the car or if i reverse into a parking spot.

Maybe the blown ACD pump causing it?


Pretty much same as brad tho.
Burning smells from engine bay?
Did they do the AWC reflash when u took it in? I've had a feeling that it might somehow be caused by the flash. Also did Paul give u a hard time about your mods when u took it in?
Offline
 
Reply With Quote
Old Jan 4, 2010, 08:59 PM   #14
Evolved Member
Personal Sales Rating: (7)
Garage is empty, add now
 
brads09lancerGT's Avatar
 
Join Date: Aug 2008
Location: BC, Canada
Posts: 1,054

Drives: 09 Octane Blue Ralliart ...09 Lancer GTS(TOTALLED)

Quote:
Originally Posted by Jyrk View Post
Also the smell seems to come from the rear of the car.. I can notice it very heavily when i stand at the back of the car or if i reverse into a parking spot.

Maybe the blown ACD pump causing it?
I asked Valley Mits about that too about the smell coming from the exhaust area and they said it was the exhaust over heating. Driving 5 mins at 60km/h over heats the RA exhaust?
Offline
 
Reply With Quote
Old Jan 4, 2010, 09:24 PM   #15
Evolving Member
Personal Sales Rating: (1)
Garage is empty, add now
 
Jyrk's Avatar
 
Join Date: Mar 2009
Location: Canada
Posts: 383

Drives: 09 Lancer Ralliart

Quote:
Originally Posted by brads09lancerGT View Post
Did they do the AWC reflash when u took it in? I've had a feeling that it might somehow be caused by the flash. Also did Paul give u a hard time about your mods when u took it in?

I actually went back to stock, Really didn't want the trouble with no warranty (or fighting with the morons in service) since i will be giving the car to the wifey.

About the AWC reflash, those morons don't know what the **** they are doing in there.. i dropped my car off at 6am. never once got a call to tell me it was done all day. so i dropped in there at 3pm and they said it was done.
All he could repeat over and over to me when i asked questions about recalls and reflashes was.. "uuhhh they have a check list they go over, and if its on the list they do it".
The print out told me nothing about what they did, even tho he said they did a recall for the airbag sensor or something.
I signed a few pages that stated i gave them authority to work on my car and away i went, with really no clue what was even done to my car. other then the fact that i now know my ACD pump is burnt out and they ordered me a new one, i still have no real proof they even did the airbag sensor or reflash since i can't get a straight answer from them.

Funny thing also. i called today to see if the pump has arrived since its been over 2 weeks since they said it was ordered. He couldn't tell me if it was ordered or not, His exact words no lies. "I am just a stupid service guy, i gotta wait to see the part to know if it got here". I hung up and repeatedly punched myself in the face for ever buying a car from these guys.

And no for all you " go to another dealership " guys. I would but the 3 1/2 hour drive to the next closest one really isn't it worth it.


Quote:
Originally Posted by brads09lancerGT View Post
I asked Valley Mits about that too about the smell coming from the exhaust area and they said it was the exhaust over heating. Driving 5 mins at 60km/h over heats the RA exhaust?
Yes exhaust really smells like burning rubber
when I drive for 30 mins or so and stop at a red light, the whole car starts to stink like burning rubber. Its not even a slight smell either.. Kinda annoyed by it really.

I am just waiting for my car to catch fire one day, and they give me a fire extinguisher for the recall.
__________________
(x) Change in the ashtray
(x) a pack of gum in the cup holder
(x) performance wiper fluid
(x) oil change
(x) another pointless list nobody cares about

Last edited by Jyrk; Jan 4, 2010 at 10:56 PM.
Offline
 
Reply With Quote
Old Jan 4, 2010, 09:24 PM
EvolutionM
Mitsubishi Lancer




Paid Advertisement
 
 
 
Reply

Tags
2009, back, burned, burning, clutch, evo, evolution, evolutionm, forum, mitsubishi, octane, ralliarts, rubber, smell, subaru, tire

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


 









All times are GMT -7. The time now is 06:07 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.5.2
All Passwords